All completed successfully, If you wake to find no internet, please unplug the power plug and reboot your router, radio and/or chorus fiber box. If this still doesn't fix it, please reach out
Posted Mar 12, 2026 - 03:33 NZDT
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Mar 12, 2026 - 00:15 NZDT
Update
We will be undergoing scheduled maintenance during this time.
Posted Mar 01, 2026 - 12:09 NZDT
Scheduled
RESCHEDULED We will be undergoing core upgrades during this time, we expect total downtime to be less then 3 hours.
Posted Mar 30, 2026 - 00:00 NZDT
This scheduled maintenance affected: Fiber Network, Coromandel Wireless, Huia/Little Huia Wireless, Far North Wireless, Cornwallis Wireless, Parau Wireless, Port Charles ( Northern Coromandel Wireless ), Colville Wireless, Papa Aroha Wireless, and Te Kouma Wireless.