The scheduled maintenance has been completed. Please power reboot your router,ONT and or Radio if your still not back online, Please DO NOT reset any component
Posted Sep 04, 2026 - 22:28 NZST
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Sep 04, 2026 - 22:00 NZST
Scheduled
We will be performing an emergency software upgrade across our core network infrastructure to ensure continued stability, performance, and security. Customers will experience some brief interruptions of service (typically lasting 2-5 minutes while devices reboot and apply updates). Thank you for your patience while we keep the network running smoothly!
Posted Sep 04, 2026 - 15:33 NZST
This scheduled maintenance affected: Fiber Network, Coromandel Wireless, Huia/Little Huia Wireless, Far North Wireless, Cornwallis Wireless, Parau Wireless, Port Charles ( Northern Coromandel Wireless ), Colville Wireless, Papa Aroha Wireless, and Te Kouma Wireless.